サポート ツール プラグイン経由のサポート リクエストの送信中にエラーが発生する
プラットフォームについて: Data Center のみ。 - This article only applies to Atlassian apps on the Data Center プラットフォーム。
この KB は Data Center バージョンの製品用に作成されています。Data Center 固有ではない機能の Data Center KB は、製品のサーバー バージョンでも動作する可能性はありますが、テストは行われていません。 Server* 製品のサポートは 2024 年 2 月 15 日に終了しました。Server 製品を実行している場合は、 アトラシアン Server サポート終了 のお知らせにアクセスして、移行オプションを確認してください。
*Fisheye および Crucible は除く
症状
The UI shows an error that begins with "An error occurred while creating your support request email:"
atlassian-confluence.logに次のエラーが返される。
2012-07-16 19:04:11,199 ERROR [http-8080-8] [support.tools.action.SupportToolsAction] execute
Error creating or sending your support request:
-- url: /plugins/servlet/stp/view/create-support-request/execute | userName: admin | referer:
http://localhost:8090/plugins/servlet/stp/view/
java.lang.ClassCastException: java.util.ArrayList cannot be cast to
com.atlassian.support.tools.properties.PropertyStore
at com.atlassian.support.tools.salext.AbstractSupportApplicationInfo.loadStore(AbstractSupportApplicationInfo.java:427)
at com.atlassian.support.tools.salext.AbstractSupportApplicationInfo.saveProperties(AbstractSupportApplicationInfo.java:397)
at com.atlassian.support.tools.salext.mail.AbstractMailUtility.sendSupportRequestMail(AbstractMailUtility.java:30)
原因
This is caused by a known bug in the Support Tools Plugin and is being tracked in STP-158.
ソリューション
The bug is fixed in version 3.0.8 of the STP plugin, so visit the Confluence Admin >> Manage Plugins page and update the Support Tools Plugin, which is located under the System Plugins section.
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