Users cannot be found in Users list and ACTIVE flag for users set to F in the database

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Problem

Unable to grant user access to Crucible/Fisheye as a user cannot be found when searching for him in "Users" to add the required groups.

Diagnosis

Diagnostic Steps

set ACTIVE=F for user in the database. Run below query to check that

1 select * from cwd_user where user_name='username';

Cause

User directory cache is not updated with changes in remote directory

Solution

Resolution

Do a force "full synchronization" for the directory configuration as mentioned below

  • In the Fisheye User Interface go to Administration > User Directories

  • Click on the "edit" button in the "Active Directory server" row

  • In that User Directories settings, uncheck the box next to "Enable Incremental Synchronisation"

  • Switch back to the User Directories page and select "Synchronize" and wait until it finishes

Once the issue is resolved, you may change it back to incremental synchronisation by checking "Enable Incremental Synchronisation"

Updated on April 8, 2025

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