Unable to view or open a review - Your request was unable to be processed - NullPointerException

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

A review cannot be viewed and results in an error on screen after clicking on it - "Your request was unable to be processed". The following error appears in the log fisheye.out:

1 2 3 4 5 6 7 8 9 10 11 2013-04-01 00:09:06,399 ERROR - Exception "javax.servlet.ServletException: javax.el.ELException: java.lang.NullPointerException" (javax.servlet.ServletException) while processing "/cru/TEST_PROJECT-224" (Referer:"null") javax.servlet.ServletException: javax.servlet.ServletException: javax.el.ELException: java.lang.NullPointerException ... Caused by: javax.servlet.ServletException: javax.el.ELException: java.lang.NullPointerException ... 100 more Caused by: javax.el.ELException: java.lang.NullPointerException ... 175 more Caused by: java.lang.NullPointerException ... 190 more

Diagnosis

Run the following database queries and post the results in a comment on this ticket:

This query will return a cru_review_id for the review:

1 select * from cru_revpermaid t where t.cru_proj_key='TEST_PROJECT' and t.cru_number=224;

Next, run the following query with the previously acquired cru_review_id:

1 2 3 select t.cru_participant_id, cru_user, cru_author from cru_review_participant t where t.cru_review_id=<CRU_REVIEW_ID_HERE>;

Cause

The author field will be blank and thus the reason for the NullPointerException. To work around this we can temporarily assign an author to the review or delete the hung review manually.

Solution

Resolution

You can assign any of the users to be the author:

  • Make a backup of the database.

  • You can find a user's number by querying the table with their username using the following query:

    1 select cru_user_id from cru_user where cru_user_name='<user_name_here>';
  • Then, match the user with cru_participant_id and run this command to set the author to TRUE:

    1 update cru_review_participant set cru_author=1 where cru_participant_id=<CRU_PARTICIPANT_ID>;

Updated on April 24, 2025

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