Unable to see JIRA issues from Crucible

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

Applink is configured but unable to see JIRA issues from Crucible

The following appears in the Crucible logs

1 2 3 4 5 6 7 8 9 10 11 12 13 2015-04-07 03:12:45,913 DEBUG [btpool0-1240 ] fisheye JiraIssueServiceImpl-logException - Error retrieving issue 'PROA-73' from JIRA server at http://jira.example.com/browse/PROA-73 java.lang.IllegalArgumentException: duplicate key: PROA at com.google.common.base.Preconditions.checkArgument(Preconditions.java:115) at com.google.common.collect.RegularImmutableMap.<init>(RegularImmutableMap.java:72) at com.google.common.collect.ImmutableMap$Builder.fromEntryList(ImmutableMap.java:221) at com.google.common.collect.ImmutableMap$Builder.build(ImmutableMap.java:207)

Cause

There are multiple projects with the same Project Key in JIRA.

Resolution

Change the project key for one of the projects, or delete the entire project if it is not used and empty

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.