Unable to add Perforce repository

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Test connection will fail with the following error:

1 2 3 4 5 6 7 8 Error testing connection. Unable to get repository info: Unable to login: com.atlassian.utils.process.ProcessNotStartedException:p4 could not be started at com.cenqua.fisheye.perforce.client.P4Client.info(P4Client.java:83) at com.cenqua.fisheye.perforce.P4ScmConfig.testConnection(P4ScmConfig.java:162) at com.cenqua.fisheye.perforce.P4ScmConfig.testConnection(P4ScmConfig.java:155) at com.cenqua.fisheye.RepositoryConfig.testConnection(RepositoryConfig.java:442) at com.atlassian.fisheye.spi.admin.impl.DefaultRepositoryAdminService.testConnectionFor(DefaultRepositoryAdminService.java:588) Connection failed.

Cause

Fisheye/Crucible unable to use Perforce command-line client to connect to Perforce server.

Resolution

Setup Perforce command-line client according to this documentation: Perforce client

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.