There are no links available when using anonymous access error when adding Application Link to a project
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
When trying to add a Application Link to a project in Fisheye/Crucible you see the following error message:
"Sorry, there are no links available when using anonymous access, check the permission configuration of the remote application."

The following appears in the atlassian-fisheye-YYYY-MM-DD.log
:
1
2
2014-07-18 07:51:43,966 WARN [qtp1374821456-850060 ] org.apache.commons.httpclient.HttpMethodDirector HttpMethodDirector-processWWWAuthChallenge - Unable to respond to any of these challenges: {oauth=OAuth realm="https%3A%2F%2Fserver.domain.com"}
2014-07-18 07:51:43,972 WARN [qtp1374821456-850060 ] com.atlassian.applinks.core.rest.PermissionResource PermissionResource$4-handle - Authentication failed for application link test (241a7975-7954-34fd-93ec-79b69abd1b11) http://server.domain.com com.atlassian.applinks.application.jira.JiraApplicationTypeImpl@2606e933. Response headers: {WWW-Authenticate=OAuth realm="https%3A%2F%2Fserver.domain.com", Content-Length=174, Set-Cookie=atlassian.xsrf.token=AELW-B7TV-AG26-I6W7|2ce0941123455ea740dc68dc4aecbdfde8c8|lout; Path=/, X-Seraph-Trusted-App-Error=APP_UNKNOWN; Unknown Application: {0}; ["AE81A0D30112345F8124C17500108F992"], X-AUSERNAME=anonymous, Connection=close, Server=Apache-Coyote/1.1, Cache-Control=no-transform, Date=Fri, 18 Jul 2014 07:51:43 GMT, Vary=Accept, X-Seraph-Trusted-App-Status=ERROR, Content-Type=application/xml;charset=UTF-8, X-AREQUESTID=471x1123481855x1} body: <?xml version="1.0" encoding="UTF-8" standalone="yes"?><status><status-code>401</status-code><message>Client must be authenticated to access this resource.</message></status>
Cause
This caused by the Outgoing Authentication configuration for OAuth not being configured correctly and missing valid credentials
Resolution
Supply valid Administrator credentials for OAuth under Outgoing Authentication in the Application Link:
Navigate to
Administration >> Global Settings >> Application Links
Click Edit next to the Application Link causing the error
Select Outgoing Authentication then the OAuth tab
Provide valid administrator credentials for the application you're linking to and click Login
If setting up outgoing OAuth credentials does not work, you may need to delete and re-create the Application Link.
Was this helpful?