The Server ID associated to my Atlassian product license does not match the Server ID from my Atlassian product instance
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
The Server ID associated to my Atlassian product license (e.g. Fisheye and Crucible, Bamboo and so on) inside my.atlassian.com does not match the Server ID from my Atlassian product instance.
Diagnostic Steps
We will use Fisheye and Crucible in this example. This applies to other Atlassian products on the server platform as well.
The license key string inside Fisheye and/or Crucible matches the license key string inside my my.atlassian.com account.
The Support Entitlement Number (SEN) inside Fisheye and/or Crucible matches the Support Entitlement Number (SEN) inside my.atlassian.com.
The Server ID inside the Fisheye and/or Crucible Administration > System Settings > System Info page differs from the one inside my.atlassian.com.


This does not apply to non-production installations that are used for testing and development of Fisheye and/or Crucible. You should be using developer licenses in such case. Developer licenses have different license keys when compared to the existing commercial or academic server license they're associated to.
Cause
This is most commonly perceived after a) an application migration or b) application upgrade. Migrating or upgrading your Atlassian product sometimes require downloading and setting up a new installation of the Atlassian product.
Every new Atlassian product installation has a different Server ID. The only way to keep using the same Server ID that was associated to your license the first time it was generated would be to keep using the same Atlassian product installation.
Resolution
The Server ID is an identifier for your Atlassian product instance and it's simply associated with the license, not generated by it. Server IDs are used for Atlassian internal tracking only.
In case you're migrating or upgrading your Atlassian product you will use the same license key in the new Atlassian product installation, there's no need to change the Server ID or obtain a new licensing key. Your license is not tied to (or restricted to) a specific Server ID.
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