Subversion Client Exception - SVN: E175002: No route to host svn
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Symptoms
The following appears in the atlassian-fisheye-YYYY-MM-DD.log:
1
2
3
Repository paused due to error com.cenqua.fisheye.rep.RepositoryClientException: org.tigris.subversion.javahl.ClientException: svn: E175002: No route to host svn
...
Diagnosis
Check if the Subversion repository is reachable by running the svn info <repository url> and also check if the path of the repository is correct
Cause
There are two possible causes for this error:
The Subversion server is offline or unreachable from the Fisheye instance
The repository path from the Subversion server might have changed resulting in the error being thrown
Solution
Resolution
For the causes mentioned above the resolutions are:
Ensure that the Subversion server gets on-line for the instance to be able to connect to it.
Change the path for the repository if the path had been changed and perform a full reindex under
Administration > Repository Settings > Repositories > <Repository Name> > Maintenance > Repository Source Index > Re-index
.
Was this helpful?