Restore Fails, Upgrade Fails: Not a valid Fisheye and Crucible backup archive

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

The Fisheye/Crucible "restore" feature of fisheyectl fails when upgrading from version 1.6.X to 2.X with the following error:

1 2 3 4 ./fisheyectl.sh restore -f backup_20120407121212.zip INFO - FishEye arguments: [-f, backup_20120407121212.zip] INFO - Cache-sizing: MAX_TOTAL_CACHE_SIZE=343005555 Not a valid FishEye and Crucible backup archive.

Cause

Built-in "restore" functionality is only found in Fisheye/Crucible version 2.x and up.

Resolution

As described in the Fisheye/Crucible 1.6 documentation, simply unzip the backup in the FISHEYE_INST directory of the new installation:

  1. Install – but do not start – the latest version of Fisheye/Crucible 2.X.

  2. Define a FISHEYE_INST environment variable and point it to an empty directory.

  3. Unzip the 1.6.X backup zip into the FISHEYE_INST directory.

  4. Start Fisheye/Crucible.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.