Recent commits are not visible in Crucible review
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Recent commits are not visible in Crucible review. When tried to browse change sets while creating a review, the latest commits don't appear in Crucible
Environment
Fisheye/Crucible version 4.5.0. May be applicable for other versions of Fisheye
SCM tool - Bitbucket
Repository type - Git
Diagnosis
There are no specific errors in the logs. We can see the recent commits are indexed in Fisheye.
1 2 3
YYYY-MM-DD 10:38:17,111 INFO [IncrPing1 myrepo ] fisheye BaseRepositoryScanner-ping - processing repository myrepo (myrepo) YYYY-MM-DD 10:38:17,111 INFO [IncrPing1 myrepo ] fisheye LifecycleRepositoryScanner-doSlurpTransaction - Starting slurp of myrepo (myrepo) YYYY-MM-DD 10:38:17,111 INFO [IncrPing1 myrepo ] fisheye BaseRepositoryScanner-ping - done slurp for repository myrepo (myrepo) time = 0 ms
Verify if you have 2 different users Bob (bob@atlassian.com) and bob (bb@atlassian.com) while browsing change sets. One of the user has a profile picture, while the other doesn't have. The commits from the bb@atlassian.com are not showing.
Navigate to Review >> Add Content >> Browse change sets >> TypeanyunderUserand click apply. Verify if the latest commits (which were missing before) show up now.
Cause
The users have different emails Bob (bob@atlassian.com , bb@atlassian.com) in the commits. The user bb@atlassian.com does not exists in SCM or Crucible, but the user bob@atlassian.com exists in SCM and alsoCrucible. When the user Bob with email (bob@atlassian.com) pushes as commit, it appears both in SCM and Crucible. Whereas the user with bb@atlassian.com pushes a commit, it doesn't appear. Its caused due to missing user in SCM, Crucible.
Solution
To associate user bb@atlassian.com commits to Crucible user bob@atlassian.com you could do the following:
Navigate toAdministration >> UserSettings >> User Mappings.
Select the repository underAdd a new user mappingand clickAdd.
Select user bob with bb@atlassian.com underCommitter usernameandBob with email bob@atlassian.comunderFisheye username.
ClickAdd.
Confirm if the commits are now visible in Crucible.
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