Problem starting a full reindex on repository - Current repository index is not compatible with your license
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
The repository is in ERROR status and the following message can be see in the logs:
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2012-06-08 12:59:48,749 WARN [btpool0-4 ] fisheye.app RepositoryAdminRpcServiceImpl-performFullReindex - Problem starting a full reindex on repository <REPO_NAME>
com.atlassian.fisheye.spi.admin.services.RepositoryConfigException: Problem loading repository '<REPO_NAME>' - Current repository index for "<REPO_NAME>" is not compatible with your license, please re-index.
...
Caused by: com.cenqua.fisheye.config.ConfigException: Current repository index for "<REPO_NAME>" is not compatible with your license, please re-index
...
Cause
There is only a Crucible license installed. A Fisheye license is needed in order to index and browse the repositories. OR
Crucible have its own light-weighted indexer which has a complete different structure than Fisheye if you have installed Fisheye at a later stage
Resolution
Obtain a Fisheye license and apply it under
Administration > System Settings > System Info > Edit License
. A license can be obtained via MyAtlassian. ORA full reindex of the repository should help as well. You can do this by navigating to
Crucible Administration Area >> Repositories >> Select the repository >> Maintenance >> Repository Source Index >> Re-clone and Re-index >> Start
.
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