Permission Denied errors in the JIRA ticket's source tab

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

The following message is displayed on the Source tab in a JIRA issue:

Repository [name hidden] on http://<fisheye_host>:8060/ failed: PERMISSION DENIED

Although this message is shown, some changesets may be listed.

Causes

Cause 1: Although the JIRA user exists in Fisheye side as well, the repository does not allow the user to access its changesets

Cause 2: Wrong Project Links configuration

Resolutions

For Cause 1 mentioned above: Go to the Fisheye repository permissions and allow access to the group to which the user belongs.

For Cause 2 mentioned above: Go to the Project Link configuration in the JIRA project and double-check the repositories associated to it. Sometimes there are no repositories associated.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.