Perforce repository cannot be added

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Problem

When you try to add a Perforce repository in Fisheye, the following appears in the atlassian-fisheye.log:

1 2 3 4 5 2013-07-05 08:53:10,109 ERROR [qtp637475101-161 ection-1373032389875] fisheye RepositoryAdminRpcServiceImpl-testRepositoryConnection - Connection failed. 2013-07-05 08:57:36,432 INFO [IntiPing1 reponame] fisheye BaseRepositoryScanner-ping - processing reponame 2013-07-05 08:57:36,495 INFO [IntiPing1 reponame] fisheye P4ScmConfig-testConnection - Perforce Server Version: P4D/NTX64/2012.2/551823 (2012/11/09) 2013-07-05 08:57:36,495 INFO [IntiPing1 reponame] fisheye P4ScmConfig-testConnection - Perforce Server Time: 2013/07/05 08:57:36 -0500 Central Daylight Time 2013-07-05 08:57:36,542 WARN [IntiPing1 reponame] fisheye P4Client-getLatestRevision - Non-zero exit status determining latest revision: com.atlassian.utils.process.ProcessException:Non-zero exit code: 1 | Access for user 'SYSTEM' has not been enabled by 'p4 protect'.

Diagnosis

You are running Fisheye as a Windows service, and SYSTEM is the account used to start the service.

However, running p4 protect -o in a command line client shows (among other users):

1 super user <p4_user_name_here> * //...

The above output shows that <p4_user_name_here> is a super user, while users with readprivilege should be enough to be used in Fisheye.

And you are specifying this <p4_user_name_here> user in the repository configuration page in Fisheye:

(Auto-migrated image: description temporarily unavailable)

So, Fisheye is not really using the SYSTEM account to authenticate with the Perforce server. Hence, the error message is misleading.

Cause

A wrong Charset is being used.

Solution

Resolution

Make sure that UTF-8 has been chosen as Charset:

(Auto-migrated image: description temporarily unavailable)
Updated on April 8, 2025

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