Perforce indexing fails - Request too large
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
When trying to index a P4 Repository
in Fisheye it keeps getting the following ERROR
:
1
Repository paused due to error com.cenqua.fisheye.perforce.client.P4ClientException: com.atlassian.utils.process.ProcessException:Non-zero exit code: 1 | Request too large (over 100000); see 'p4 help maxresults'.
Cause
The maxresults value associated with the group of the Fisheye user is limiting the index. The default value is "unlimited" but a superuser can use p4 group to limit maxresults for a particular group. Users in the group cannot run any commands that affect more database rows than the maxresults limit. For most commands, the number of database rows affected is roughly equal to the number of files affected.
Resolution
Set the maxresults back to unlimited or you can get around this by syncing smaller sets of files at a time.
For more information about the maxresults problem please refer to the following P4 documentation: http://kb.perforce.com/AdminTasks/PerformanceTuning/MaximizingPe..Performance
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