NullPointerException is thrown when trying to change Crucible project key

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

The following appears in the atlassian-fisheye-<date>.log:

1 2 3 4 5 6 7 8 9 10 11 12 13 2009-09-15 10:04:08,890 ERROR [btpool0-283] org.mortbay.log org.mortbay.log.Slf4jLog-warn - /fisheye/admin/updateProject.do java.lang.NullPointerException at com.atlassian.fisheye.jira.DefaultJiraServerManager.updateCrucibleProjectKey(DefaultJiraServerManager.java:394) at com.cenqua.crucible.model.managers.impl.DefaultProjectManager.changeProjectKey(DefaultProjectManager.java:100) at com.cenqua.crucible.actions.admin.project.ProjectDataFactory.updateProject(ProjectDataFactory.java:40) at com.cenqua.crucible.actions.admin.project.UpdateProjectAction$1.doInTransaction(UpdateProjectAction.java:55) at com.cenqua.crucible.actions.admin.project.UpdateProjectAction$1.doInTransaction(UpdateProjectAction.java:31) at com.atlassian.fisheye.spi.TxTemplate.execute(TxTemplate.java:137) at com.cenqua.crucible.actions.admin.project.UpdateProjectAction.execute(UpdateProjectAction.java:31) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:597)

Cause

This is a bug in Crucible CRUC-2202 - NPE thrown when trying to change project key

Workaround

  1. Backup Fisheye/Crucible for rollback purposes

  2. Stop Fisheye

  3. Run the following SQL command to clean the DB:

    1  delete from cru_revpermaid where cru_review_id is null;
  4. Restart Fisheye/Crucible

Resolution

Upgrade to Fisheye/Crucible 2.10.0+

Updated on April 8, 2025

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