Login fails due to Requested array size exceeds VM limit error
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
After upgrading, users are not able perform login. When submitting credentials page shows a constant state of working and never perform login. The following error message appears inside logs:
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2012-07-02 11:53:53,768 WARN [StreamsCompletionService::thread-874 ] fisheye.app com.cenqua.fisheye.user.crowd.CrowdAuth-getGroupsForUser - Problem communicating with Crowd
com.atlassian.crowd.exception.OperationFailedException: Requested array size exceeds VM limit
Cause
Application attempted to allocate an array that is larger than the heap size. In most cases the problem is either a configuration issue (heap size too small), or a bug that results in an application attempting to create a huge array, for example, when the number of elements in the array are computed using an algorithm that computes an incorrect size.
Resolution
Increase the heap size memory as per this document.
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