Local user can't login when using Crowd SSO

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

When Fisheye/Crucible is setup with Crowd SSO, local user can't login anymore.

The following appears in the atlassian-fisheye-<date>.log:

1 2013-07-15 10:11:26,318 WARN - cannot authenticate user "localuser" because user's auth type [built-in] is not configured, and is logging in with auth type [crowd]

Cause

Since Crowd SSO is enabled, it is not possible to use local users to login into Fisheye/Crucible.

Resolution

  1. Set the local user to authenticate with Crowd at Administration > User Settings > Users

  2. Add the local user from Fisheye/Crucible into Crowd server manually

Updated on April 8, 2025

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