Frequently being logged out of Fisheye or Crucible when using Crowd
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
Using Crowd to manage Fisheye users for authentication users are frequently logged out of Crucible/Fisheye, sometimes as often as every 5 minutes.
Cause
If you have a proxy set up between your user and Fisheye then the issue occurs because the proxy is sending its IP, which doesn't match the users IP hence the token generated for Crowd is not used forcing the user to log in again.
If you don't have a proxy set up and if you are using 'in memory tokens' with Crowd, there is a known issue which causes this problem, please see CWD-933.
To check if you are using in memory token caching, go to the Crowd 'Administration' tab, then to 'Session Config' and check if you have 'Memory Cache' selected as explained on the Crowd Session configuration page.
Resolution
If your issue is being caused by the proxy, you need to add the IP address of your proxy as a trusted proxy in Crowd's Administration page. See the Configuring Trusted Proxy Servers page on how to add this.
If you have the issue reported at CWD-933, to work around this, you can either select 'Database Cache', or change the memory cache timeout parameters as described in CWD-933.
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