Fisheye states 'Your maintenance has expired, you will need to extend the maintenance on you license to upgrade' - but the license is still valid.

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

At the bottom of each Fisheye page the following message is displayed;

(Auto-migrated image: description temporarily unavailable)

*Version available number may vary.

However the maintenance license is not expired.

Cause

There is old plugin cache left over which can be seen in FISHEYE_INST/config.xml;

1 value="%23java.util.List%0A"/><property name="com.atlassian.upm:notifications:notification-evaluation.expired" value="%23java.util.List%0A"/><property name="com.atlassian.upm:notifications:notification-evaluation.nearlyexpired" value="%23java.util.List%0A"/><property name="com.atlassian.upm:notifications:notification-maintenance.expired" value="%23java.util.List%0A"/><property name="com.atlassian.upm:notifications:notification-maintenance.nearlyexpired"

Resolution

Versions up to 2.9.x

Ensure the user running Fisheye has correct permissions regarding the folder hierarchy (and contained files) starting with the FISHEYE_INST/cache/plugins folder. If the permissions are correct, do the following:

  1. Shutdown Fisheye.

  2. Delete (or move for backup purposes) the entire folder:

    1. FISHEYE_INST/cache/plugins (e.g. /fisheye/cache/plugins)

  3. Restart Fisheye.

Versions 2.10+

Ensure the user running Fisheye has correct permissions regarding the folder hierarchy (and contained files) starting with the FISHEYE_INST/cache/plugins folder. If the permissions are correct, do the following:

  1. Shutdown Fisheye.

  2. Delete (or move for backup purposes) the entire folder:

    1. FISHEYE_INST/var/osgi-cache (e.g. /fisheye/var/osgi-cache)

  3. Restart Fisheye.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.