Fisheye Logs Report org.mortbay.jetty.EofException

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

Fisheye reports a number of following similar exceptions in the atlassian-fisheye-YYYY-MM-DD.log:

Exception

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 2013-06-27 05:40:09,195 ERROR [btpool0-6515 ] fisheye TotalityFilter-logExceptionDetails - Exception "null" (org.mortbay.jetty.EofException) while processing "/avatar/<Username>" (Referer:"http://<URL>/") org.mortbay.jetty.EofException at org.mortbay.jetty.HttpGenerator.flush(HttpGenerator.java:791) at org.mortbay.jetty.HttpGenerator.complete(HttpGenerator.java:678) at org.mortbay.jetty.HttpConnection.commitResponse(HttpConnection.java:653) at org.mortbay.jetty.HttpConnection$Output.close(HttpConnection.java:997) Caused by: java.io.IOException: Connection reset by peer at sun.nio.ch.FileDispatcherImpl.write0(Native Method) at sun.nio.ch.SocketDispatcher.write(SocketDispatcher.java:47) at sun.nio.ch.IOUtil.writeFromNativeBuffer(IOUtil.java:94) at sun.nio.ch.IOUtil.write(IOUtil.java:65) at sun.nio.ch.SocketChannelImpl.write(SocketChannelImpl.java:450) at org.mortbay.io.nio.ChannelEndPoint.flush(ChannelEndPoint.java:170) at org.mortbay.io.nio.SelectChannelEndPoint.flush(SelectChannelEndPoint.java:221) at org.mortbay.jetty.HttpGenerator.flush(HttpGenerator.java:720) ... 57 more

There is no apparent error on screen and no particular action that seems to trigger it.

Cause

These exceptions are caused when a user's browser terminates a connection, for whatever reason. They typically happen if a user shuts a browser tab while it is loading, or navigates away from the current page before the page itself is fully loaded or one of the items on the page (e.g. the avatar image) has finished being sent.

Resolution

These exceptions are totally harmless and can be safely ignored. Other than adding some noise to the Fisheye logs, they do not indicate any problems with the application itself.

Updated on April 8, 2025

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