Fisheye/Crucible stopped with InfinityDB exception

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

The following appears in the UI:

Your request was unable to be processed com.cenqua.fisheye.rep.DbException - com.atlassian.util.concurrent.LazyReference$InitializationException: com.cenqua.fisheye.rep.DbException: java.io.IOException: InfinityDB has been subject to an Internal Exception. Use close() or rollBack(). (No space left on device) File=/opt/fisheye/var/cache/reponame/revcache/data.bin

Cause

There is no disk space left on the device.

Resolution

Increase the disk space in the machine.

Updated on April 8, 2025

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