ERRORS "at com.cenqua.fisheye.user.UserLogin.<init>" after migrating your users to LDAP User Management

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Errors like the following are found in the Fisheye/Crucible debug logs after migrating users to LDAP User Management:

1 2 3 4 5 6 7 2012-04-16 10:35:29,822 ERROR [btpool0-23225 ] org.mortbay.log org.mortbay.log.Slf4jLog-warn - /rest-service-fe/changeset-v1/listChangesets/ java.lang.NullPointerException at com.cenqua.fisheye.user.UserLogin.<init>(UserLogin.java:16) at com.cenqua.fisheye.user.DefaultUserManager.createTrustedUserLoginImpl(DefaultUserManager.java:784) at com.cenqua.fisheye.user.DefaultUserManager.createTrustedUserLogin(DefaultUserManager.java:753) at com.cenqua.fisheye.user.DefaultUserManager.createTrustedUserLogin(DefaultUserManager.java:761) ...

Cause

This is a LDAP integration issue. Specifically, the errors indicates a problem with Case Sensitive Usernames.

Resolution

Use the option to force imported usernames to be lowercase and subsequently re-sync the users:

To force lowercase usernames, carry out the following steps:

  1. Log into Fisheye's Admin Interface.

  2. Under Authentication settings, the option Force Lowercase Username can be toggled on and off.

  3. With this setting switched On, when new users are added to Fisheye from an external authentication source, all usernames will be converted to lowercase.

Updated on April 15, 2025

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