Error testing connection for Perforce repository - The authenticity can't be established

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

When attempting to setup a Perforce repository for the first time, the following appears in the Fisheye/Crucible UI:

1 2 3 4 5 6 7 8 9 10 11 12 Error testing connection. Unable to get repository info: com.atlassian.utils.process.ProcessException:Non-zero exit code: 1 | The authenticity of '10.10.10.10:1666' can't be established, this may be your first attempt to connect to this P4PORT. The fingerprint for the key sent to your client is 44:81:E3:9B:12:3D:12:00:EE:AB:4D:C8:F6:DB:52:98:9C:61:B9:95 To allow connection use the 'p4 trust' command. at com.cenqua.fisheye.perforce.client.P4Client.info(P4Client.java:83) at com.cenqua.fisheye.perforce.P4ScmConfig.testConnection(P4ScmConfig.java:161) at com.cenqua.fisheye.perforce.P4ScmConfig.testConnection(P4ScmConfig.java:154) at com.cenqua.fisheye.RepositoryConfig.testConnection(RepositoryConfig.java:441) at com.atlassian.fisheye.spi.admin.impl.DefaultRepositoryAdminService.testConnectionFor(DefaultRepositoryAdminService.java:845) Connection failed.

Cause

  1. The Perforce client has never connected to the Perforce server at 10.10.10.10 and does not trust it.

  2. If you are using ticket-based authentication you may have invalid outstanding tickets.

Resolution

  1. As the user that runs the Fisheye/Crucible instance, run the following command to tell the Perforce client that this server is trusted:

    1 p4 trust -i 10.10.10.10:1666 44:81:E3:9B:12:3D:12:00:EE:AB:4D:C8:F6:DB:52:98:9C:61:B9:95

    More information about the p4 trust command line options can be found in Perforce documentation.

  2. Add a ticket to the user running Fisheye with a command like:

    1 p4 -u fisheye_user login -a

The values above will need to be updated for what is displayed from the error message.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.