Error "JVM appears hung" in wrapper.log

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Seeing the following errors in the wrapper.log file.

1 2 3 4 JVM appears hung: Timed out waiting for signal from JVM. ERROR | wrapper | 2009/02/23 03:39:39 | JVM did not exit on request, terminated DEBUG | wrapper | 2009/02/23 03:39:40 | Waiting 5 seconds before launching another JVM. STATUS | wrapper | 2009/02/23 03:39:44 | Launching a JVM...

Cause

This message usually occurs because your cpu is hitting 100% for around 30+ seconds.

See the article http://lists.hippo.nl/pipermail/hippocms-dev/2006-April/001488.html.

(Fisheye may use high CPU during the indexing process, or the high cpu may be caused by another application like svn).

Resolution

Try adding the parameter

1 wrapper.ping.timeout=120

to your wrapper.conf file, to increase the timeout period and thus prevent the JVM from being terminated. You will need to restart your server after setting this value.

Updated on April 11, 2025

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