Diffs fail for recognized file types

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Problem

The diff view does not show up for some files with an extension that normally shows diffs (e.g. .java).

Diagnosis

View both a file that successfully display the diff and one that doesn't in a text editor:

(Auto-migrated image: description temporarily unavailable)
(Auto-migrated image: description temporarily unavailable)

Cause

The file(s) have an unrecognized character encoding.

Solution

Resolution

Change the character encoding of the file(s) in question.

Updated on April 2, 2025

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