Crucible review displays text files as binary

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Both Fisheye and Crucible identify text files as binary in a Perforce repository and the P4 client installed on the Fisheye server is older than 2006.1.

If only Crucible identifies text files as binary, Fisheye correctly displays them as text, and your P4 client is newer than 2006.1, then please refer to the following page:

Cause

Fisheye can communicate with any Perforce server but it needs to use the P4 command-line client to do so. There is a bug with a P4 client older than 2006.1 that incorrectly identifies text files as binary.

Resolution

Upgrade to a more recent P4 client (2006.1 onwards) and set the filelog limit to 100, 50 or even 10.

Additionally, make sure you have set Fisheye to point to this client as per the instructions in the following page:

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.