Create review hung after upgrade or migrate to another server
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Symptoms
Clicking Create Review will have the following error:
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Server Error
Error 2
A javax.el.ELException was encountered
com.cenqua.crucible.revision.diff.patchDiff.PatchException: java.io.FileNotFoundException: /x/fecru-3.1.1/var/data/uploads/00/84/8492.dat (No such file or directory)
java.io.FileNotFoundException: /x/fecru-3.1.1/var/data/uploads/00/84/8492.dat (No such file or directory)
/x/fecru-3.1.1/var/data/uploads/00/84/8492.dat (No such file or directory)
Diagnosis
Check if the missing file exist in the older server.
Cause
Upgrade or migration is not successful cause there is some data (review path data in this case) in FISHEYE_INST
that is not moved to the new server.
Solution
Resolution
Add back the missing data in FISHEYE_INST/var/data
from the older server to the new server.
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