ConnectTimeoutException or SocketTimeoutException error in logs

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

The following error appears in JIRA / my log file:

1 org.apache.commons.httpclient.ConnectTimeoutException

or

1 org.apache.commons.httpclient.SocketTimeoutException

Cause

The cause may be a Fisheye/Crucible performance issue. To confirm that it really is Fisheye/Crucible taking a long time to respond, go to JIRA's Administration > Add-ons > Application Links and click in Fisheye Configuration for the Fisheye application link. Update the API Connection Timeout and API Socket Timeout fields.

(Auto-migrated image: description temporarily unavailable)

Resolution

If the problem is related to Fisheye/Crucible performance, then try implementing some performance improvements.

Updated on April 10, 2025

Still need help?

The Atlassian Community is here for you.