CommitException when trying to connect to Perforce server

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

When trying to connect to my Perforce Server, the following exception occurs:

1 2 3 4 com.perforce.api.CommitException java.io.IOException: Perforce client error: Connect to server failed; check $P4PORT. TCP connect to 192.168.0.79:2128 failed. connect: 192.168.0.79:2128: WSAETIMEDOUT

Cause

Your Perforce server is slow to respond and has timed out.

Resolution

Check that you can access it remotely from the command-line using p4. Ensure that the port that your Perforce server is running on is not blocked by your firewall or anti-virus software.

Search the Perforce troubleshooting documentation for the error code WSAETIMEDOUT for more possible solutions.

Updated on April 8, 2025

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