Can't Start Fisheye/Crucible from Solaris SMF

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

The following appears in the fisheye.out log:

1 2 3 4 5 6 7 8 9 10 11 12 [ Apr 19 13:53:44 Executing start method ("<FISHEYE_HOME>/bin/fisheyectl.sh run") ] WARN: your default encoding (US-ASCII) does not support unicode. This is likely to cause problems if any of the filenames, branch names or tag names in one of your repositories contain unicode characters. Update your locale settings or start with the -Dfile.encoding=UTF-8 option to avoid these problems. 2012-04-19 13:53:45,468 INFO - FishEye/Crucible 2.7.8 (20111130052542), Built on 2011-11-30 2012-04-19 13:53:45,476 INFO - Starting UpgradeManager ... 2012-04-19 13:53:48,702 INFO - FishEye: Evaluation License registered to Acme. 2012-04-19 13:53:48,724 INFO - Your license expires in 29 days 2012-04-19 13:53:55,942 INFO - Starting database... 2012-04-19 13:54:02,257 INFO - Starting plugin system... [ Apr 19 13:54:14 Method or service exit timed out. Killing contract 93 ] [ Apr 19 13:54:14 Method "start" failed due to signal KILL ]

Cause

This is caused because FishEye/Crucible is being started using the wrong command.

Resolution

Start FishEye/Crucible using the following command:

1 <FISHEYE_HOME>/bin/fisheyectl.sh start
Updated on April 15, 2025

Still need help?

The Atlassian Community is here for you.