Cannot create user even when still below the license limit

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

  • Running any Fisheye/Crucible version prior to 4.0

  • Both Fisheye and Crucible licenses configured, and allowing the same number of users. For example:

    • Fisheye (Server) 25 Users: Commercial License

    • Crucible (Server) 25 Users: Commercial License

  • Total existing users in the instance is lower than the licenses limits.

Trying to add a new user is not allowed and the following appears in the atlassian-fisheye.log:

1 016-07-18 13:12:30,210 ERROR [qtp1865859824-57005 ] fisheye TotalityFilter-logExceptionDetails - Exception "java.lang.RuntimeException: com.cenqua.fisheye.LicensePolicyException: Could not add user "test". Your license does not permit more than 25 users." (javax.servlet.ServletException) while processing "/admin/userAdd.do" (Referer:"http://localhost:8060/admin/userAdd.do")

Note: In the log message above, "25" is the maximum number of users allowed by the license. This number varies according to the licenses configured in the instance.

Cause

In Fisheye/Crucible versions prior to 4.0 there were some user count caches which were not invalidated in a timely basis when users got disabled by using the web interface (thus allowing to create new ones).

Resolution

Resolution #1:

Restart Fisheye/Crucible in order to invalidate the old caches and create new caches with the accurate user count

Resolution #2:

If the suggestion above does not help:

  1. Go to Edit License page

  2. Remove the Crucible license

  3. Save changes and refresh the Edit License page

  4. Add the same Crucible license

  5. Save changes and refresh the Edit License page

Updated on April 8, 2025

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