Cannot add <USER> but the <USER> doesn't exist in the User Management

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

When trying to create a new user the following ERROR occurs:

1 2 3 Could not execute JDBC batch update Duplicate entry '<USER>' for key 2 You are running release CR2.7.3 FE2.7.3 (20110920012939 2011-09-20), please report your release number when reporting bugs.

Cause

This is probably happening because Fisheye and Crucible are disabled for that user.

Resolution

You should query you FeCru database to check that user:

1 mysql> SELECT * cru_user_id, cru_fisheye_enabled, cru_crucible_enabled FROM cru_user where cru_user_name = <USER>;

This will bring the value for both collums, if they are empty here is the problem and we should do the following:

1 mysql> UPDATE cru_user SET cru_fisheye_enabled = '1',cru_crucible_enabled = '1' WHERE cru_user_id = '<USER_ID>';

This will enable Fisheye and Crucible for the <USER>.

Updated on April 8, 2025

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