Application was down because its files had consumed up all server space

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Users try to perform login on Fisheye and face the following UI error message:

1 2 3 "Your request was unable to be processed org.hibernate.exception.GenericJDBCException - Could not execute JDBC batch update Could not execute JDBC batch update failed batch"

Or even:

1 2 3 ***************************************************** JSP Exception *********************************************************** An error occurred trying to render this page javax.servlet.jsp.JspException: javax.servlet.jsp.JspException: javax.el.ELException: Problems calling function 'cruReview:canDo'

Also inside fisheye-error.log and fisheye-debug.log is possible to find many occurrences of the following stack trace:

1 2 3 2012-08-05 23:11:34,304 ERROR [btpool0-2910 ] org.hibernate.util.JDBCExceptionReporter org.hibernate.util.JDBCExceptionReporter-logExceptions - failed batch 2012-08-05 23:11:34,307 ERROR [btpool0-2910 ] org.hibernate.event.def.AbstractFlushingEventListener org.hibernate.event.def.AbstractFlushingEventListener-performExecutions - Could not synchronize database state with session org.hibernate.exception.GenericJDBCException: Could not execute JDBC batch update

Cause

This happens when using HSQLDB database (which comes bundled with Fisheye) in production environments (which is not recommended) and application ran out of memory to perform all requests. So application got problem to communicate with database and start to populate logs with repeated stack traces which depending on disk space available could result in application crash because of lack free of disk space..

Resolution

As workaround we recommend migrating application to an external database.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.