Application link suddenly fails - Connection lost with JIRA

Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Clicking on a JIRA link from within Fisheye/Crucible displays an error:

Connection lost with JIRA

Unfortunately, we've encountered problems connecting to JIRA: The server may be unreachable. Please ensure you are running JIRA 5.0 or higher

The following appears in the atlassian-fisheye-<YYYY>-<MM>-<DD>.log:

1 2014-02-18 10:30:58,669 WARN [qtp27134372-33094 ] com.atlassian.oauth.serviceprovider.internal.AuthenticatorImpl OAuthProblemUtils-logOAuthProblem - Rejecting OAuth request for url "http://kidney:8060/rest-service-fe/search-v1/crossRepositoryQuery" due to invalid timestamp ({oauth_problem=timestamp_refused, oauth_acceptable_timestamps=1392737158668-1392737758668}). This is most likely due to our system clock not being synchronized with the consumer's clock.

Cause

The difference in system time between the JIRA and Fisheye/Crucible servers has drifted too much, voiding the OAuth token.

Resolution

Either synchronize the server times manually or set up an NTP server to keep the server times in synch.

Updated on April 8, 2025

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