All users are unable to log in with Crucible reporting incorrect username and password despite using the correct credentials
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Problem
The users cannot log in to Crucible. The error "Incorrect username/password" is shown, however, the credentials are correct.
The issue is happening both to users from an external directory and Crucible Internal Directory.
Diagnosis
Diagnostic Steps
Login with Admin access to Crucible
Navigate to User Settings → Users and confirm that any impacted user is a member of c
rucible-users
group.Navigate to Security Settings → Authentication and check if AJP13 or Custom authentication enabled.
Cause
If the user is not a member of c
rucible-users
then the user doesn't have any access permissions, not able to log in, and doesn't consume the licenseIf the AJP13 authentication is enabled it expects the authentication token coming from AJP enabled proxy
If custom authentication is enabled Fisheye expects a special java class supporting the authentication
Solution
Resolution
Only standard password-based authentication and Crowd SSO 1.0 are the only valid and supported by Atlassian authentication approaches. You need to disable any other:
Navigate to Security Settings → Authentication,
Click Remove next to AJP13 or Custom
Confirm the choice by clicking Remove in the dialog
Don't forget to reset Captcha if enabled
After disabling custom authentication you should be able to log in again.
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