500 Error Page When Logging Into Fisheye/Crucible
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
When trying to log into Fisheye/Crucible a 500 error page is shown and the following is visible in the atlassian-fisheye-YYYY-MM-DD.log
file:
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2013-04-09 05:45:38,416 WARN - header full: java.lang.ArrayIndexOutOfBoundsException
2013-04-09 05:45:38,417 ERROR - Exception "null" (java.lang.ArrayIndexOutOfBoundsException) while processing "/login" (Referer:"http://localhost:8060/login")
java.lang.ArrayIndexOutOfBoundsException
Cause
This is a know bug in Jetty 6 when too many cookie headers are set:
Workaround
There are two possible workarounds:
Delete all the cookies in your browser and re-attempt to log into Fisheye/Crucible.
Upgrade Fisheye/Crucible to a version above 3.0 since it is shipped with Jetty 8.
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