Using reserved characters in Crowd API

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When using the Crowd API you are restricted to some definitions and one of them includes the restrictions from the RFC 3986 - Uniform Resource Identifier (URI): Generic Syntax definition, which describes a subset of reserved charactersthat must be replaced by a percent-encoded octet to make it work in a request. Please note that some names used in the Crowd UI could contain these reserved characters; to use them in a request to the Crowd API, it will be necessary to replace them by the correspondent percent-encoding.

Environment

Crowd API

Cause

Some characters are reserved due to a specific definition since they can be used as delimiters in a syntax; to avoid conflict, those characters must be percent-encoded so the request can work properly.

Solution

These are the reserved characters and their correspondent encoding:

Character

Encoding

':'

%3A

'/'

%2F

'?'

%3F

'#'

%23

'['

%5B

']'

%5D

'@'

%40

'!'

%21

'$'

%24

'&'

%26

"'"

%27

'('

%28

')'

%29

'*'

%2A

'+'

%2B

','

%2C

';'

%3B

'='

%3D

'%'

%25

' '

%20 or +

Updated on April 8, 2025

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