Users Can't Login Due to Expired Passwords

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Users are unable to log into the Crowd Application (JIRA, Confluence and etc.) because the passwords have expired. The following error is logged in Crowd logs:

1 2010-05-20 09:06:31,119 http-8095-13 INFO [integration.directory.internal.InternalDirectory] Steve.Smith: Attempting to log in with expired passsword.

Cause

When Configuring an Internal Directory, the admin can specify Maximum Unchanged Password Days property.

This value governs the number of days, until the password must be changed. If not, the user will be denied access to client application.

Prior to Crowd 2.0.4, the password expiration policy was not enforced for Crowd applications (see this bug report) This mean users with expired passwords could still log into Crowd application(s).

Resolution

There are 2 solutions:

  1. Set the Days until password expiry value to 0, this means the user password will never expire.

  2. Users can always reset their passwords, via the Crowd console.

Updated on April 8, 2025

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