Unable To Reset User Password On Crowd WAR Install
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
The following exception is thrown, when resetting user password.
1
Caused by: java.lang.NoClassDefFoundError: javax/activation/DataSource
Cause
The Crowd WAR/EAR distribution is shipped with the activation-x.x.jar file in its /WEB-INF/lib
folder, however, Tomcat needs it in its own /lib
folder.
Resolution
Move the activation-x.x.jar file from the Crowd /WEB-INF/lib
folder to the Tomcat /lib
folder (/apache-tomcat/common/lib
for Tomcat 5.X.X or /apache-tomcat/lib
for Tomcat 6.X.X) and restart Crowd
Severity: Low
Regular Expression: Caused by: java\.lang\.NoClassDefFoundError: javax\/activation\/DataSource
Article ID: CROWDKB
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