Unable to Import User or Group CSV Containing Non-ASCII Characters

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

When importing a csv containing non-ascii characters, the sample row will be blank, or the import may fail.

These errors may be present in the log:

1 2 ERROR [crowd.importer.config.CsvConfiguration] (startline 1)eof reached before encapsulated token finished java.io.IOException: (startline 1)eof reached before encapsulated token finished

Cause

Crowd is being started as a service, and is not picking up the UTF8 encoding setting, as per this bug. Default system encoding is therefore being used, and causing the import to fail.

Workaround

1) Stop Crowd 2) On the Crowd server, open a command prompt in the <CROWD-INSTALL>/apache-tomcat/bin/ directory 3) Execute this command - tomcat6 //US//Crowd ++JvmOptions="-Dfile.encoding=UTF8" where 'Crowd' is the name of your Crowd service. 4) Restart Crowd 5) Try the import again

Updated on April 8, 2025

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