Logging in to Crowd Keeps Failing and Gets Redirected Back to The Login Page

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

When a user tries to log in to Crowd, the authentication keeps failing without any error message, and instead user keeps getting redirected to login page again.

Cause

The SSO Domain for the cookies has changed while users are still logged in. Indicators include

  1. There are duplicate crowd.token_key cookies

  2. Secure SSO cookies option is enabled

  3. The SSO domain name in the General option is wrongly set

Resolution

  1. Shut down Crowd

  2. Clear your browser cookies

  3. Execute the following SQL query:

    1 UPDATE cwd_property SET property_value='false' WHERE property_name='secure.cookie';
  4. Execute the following SQL query:

    1 UPDATE cwd_property SET property_value=NULL where property_name='domain';
  5. Restart Crowd.

Please be aware that when having the domain wrongly set, the application link to Crowd will also receive the same behaviour as when logging in Crowd.

Updated on April 8, 2025

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