Inconsistent Results when Importing Users from Confluence to Crowd

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Inconsistent results when using the Atlassian Product Importer under Crowd Administration>>Import Users. For example, users may import but their disabled status may not be accurate and their group memberships may not import.

Diagnosis

The database user account entered for the importer does not have sufficient permissions to query the database.

Cause

The insufficient permissions of the database user entered for the importer permit some access but not enough to pull all the data.

Resolution

  • Use the same database user that is being used by the Confluence application to access the Confluence database in the Crowd User Importer. This username and password can be found in the file <Confluence_Home>/confluence.cfg.xml.

Updated on April 8, 2025

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