"groups section not found" error in Apache logs with Crowd Apache Connector

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Attempting to login to a Crowd-protected SVN repository results in this:

1 2 3 [Tue Jan 08 09:26:26 2013] [crit] [client 10.60.1.200] groups section not found, referer: http://10.60.1.233/svn/ [Tue Jan 08 09:26:26 2013] [error] [client 10.60.1.200] Access denied: 'admin' GET TestRepository:/, referer: http://10.60.1.233/svn/

Cause

The [groups] section in the AuthzSVNCrowdAccessFile is empty, or not even there. Example:

Groups section is empty

1 2 3 4 [groups] [/] * = r

OR

Groups section is not even there

1 2 [/] * = r

Workaround

Add a dummy group into the [groups] section, example:

1 2 3 4 5 [groups] jira-administrators= [/] * = r

Restart Apache

Updated on April 11, 2025

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