Every request when Crowd is running as a Windows Service responds with an HTTP 404 error

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Starting up Crowd with a standalone script works just fine, but using a Windows Service, all requests to /crowd return with an HTTP 404 error.

Environment

  • Crowd Server and Datacenter

  • Windows Operating System

  • Crowd running as a Windows Service

Diagnosis

There are no errors in the atlassian-crowd.log

Checking on crowd-stdout.log, we can see the following error message:

1 2020-09-24 13:06:46,157 localhost-startStop-1 ERROR [crowd.console.setup.CrowdSetupPersister] Could not save setupType:com.atlassian.config.ConfigurationException: Couldn't save crowd.cfg.xml to e:\crowd-home\shared directory.

The symptom in the UI is an HTTP 404 - Not Found message, when someone tries to access Crowd using /crowd as the context path, for example: http://<address>:<port>/crowd

Cause

The user running the Windows Service does not have full control access to the <crowd_home> and <crowd_install> directories.

Solution

Ensure that the user running the Windows Service has full read and write permissions on the <crowd_home> and <crowd_install> directories.

Updated on April 15, 2025

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