Crowd users unable to access Confluence due to 'Not Permitted' error
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
Users are (intermittently) denied access to Confluence with
Not Permitted
error. However, flushing the Confluence cache grants access to the users.The error in the
atlassian-confluence.log
is:2009-09-23 13:58:59,180 http-8095-Processor24 ERROR [console.action.group.BrowseGroups] The com.atlassian.crowd.integration.directory.caching-identifier-usnchanged32770 Cache is not alive. java.lang.IllegalStateException: The com.atlassian.crowd.integration.directory.caching-identifier-usnchanged32770 Cache is not alive. at net.sf.ehcache.Cache.checkStatus(Cache.java:1204) at net.sf.ehcache.Cache.get(Cache.java:650) at net.sf.ehcache.Cache.get(Cache.java:631) at com.atlassian.crowd.integration.directory.cache.DefaultDirectoryCache.getFromCache(DefaultDirectoryCache.java:315)
Confluence version is 3.0.1 or higher and Crowd version is prior to 2.0.2.
Cause
Confluence 3.0.1 or higher uses Ehcache which conflicts with Crowd's cache (also Ehcache).
Resolution
Upgrade Crowd to version 2.0.2 which contains the fix.
Workaround
See comment in CWD-1707 - We need to improve the CacheImpl in the integration client to programatically add caches to the ehcache manager.
Was this helpful?