Crowd server File System Corruption
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
Unable to log to crowd server
detected following error message at the atlassian-crowd.log file:
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2016-09-21 11:13:54,805 http-bio-8081-exec-170 ERROR [crowd.console.action.Login] Failed to connect to the authentication server, please check your crowd.properties
org.springframework.security.authentication.AuthenticationServiceException: Could not invoke service.. Nested exception is org.codehaus.xfire.fault.XFireFault: ParseError at [row,col]:[1,1]
Message: Premature end of file.
at com.atlassian.crowd.integration.springsecurity.CrowdAuthenticationProvider.translateException(CrowdAuthenticationProvider.java:301)
at com.atlassian.crowd.integration.springsecurity.CrowdAuthenticationProvider.authenticateUsernamePassword(CrowdAuthenticationProvider.java:164)
at com.atlassian.crowd.integration.springsecurity.CrowdAuthenticationProvider.authenticate(CrowdAuthenticationProvider.java:102)
at org.springframework.security.authentication.ProviderManager.authenticate(ProviderManager.java:156)
at com.atlassian.crowd.integration.springsecurity.DynamicProviderManagerImpl.authenticate(DynamicProviderManagerImpl.java:40)
at org.springframework.security.web.authentication.UsernamePasswordAuthenticationFilter.attemptAuthentication(UsernamePasswordAuthenticationFilter.java:94)
Cause
There is a file system corruption on either the Crowd installation folder or Home directory.
Diagnostic
Please run the disk check on the Crowd file system containing install and home directories to confirm whether we have File System Corruption or not:
On Windows: https://technet.microsoft.com/en-us/magazine/ee872425.aspx
On Linux: use the command line
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fsck <Crowd home directory path_FS> fsck <Crowd installation folder path_FS>
System admin needs to be involved to confirm corruption
Resolution
With the file system corruption, please:
Redeploy the Crowd installation folder by downloading the same version of Crowd Archived.
Restore the Crowd home directory from backup
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