Cloned Crowd instance does not allow login

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

After cloning a Crowd instance, users are unable to log in. When entering a username and password, the page refreshes back to the login page without an error.

In the logs, we can see that the user trying to log in has access to Crowd:

1 2014-12-12 15:35:32,998 http-bio-8095-exec-23 DEBUG [crowd.manager.authentication.TokenAuthenticationManagerImpl] User <xxxxx> has access to the application <crowd>

Cause

The original instance has the Secure SSO Cookie option checked under the Crowd admin console. If the instance that is being migrated to does not have SSL enabled, the users will be unable to login. The cookie that Crowd tries to create on the app server is not secure and, in turn, the application does not allow the login process to complete.

Resolution

Atlassian Support Offerings

The following SQL query is outside the scope of Atlassian Support Offerings and is provided for general guidance only.

  • Please run the following query on the database to update the cookie property value:

1 UPDATE cwd_property SET property_value = 'false' WHERE property_name='secure.cookie';
    • This query may need to be changed for different database types

  • Please restart Crowd and attempt to log in

Expand to see related content

https://confluence.atlassian.com/display/CROWD027/Migrating+Crowd+Between+Servers

Updated on April 8, 2025

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