Can't Create XML backup due to missing password

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

The following error appears in log when generating a Crowd XML backup:

1 2 3 4 2011-02-01 23:22:27,590 http-8095-15 ERROR [500ErrorPage] Exception caught in 500 page null java.lang.NullPointerException at com.atlassian.crowd.migration.UserMapper.addUserToXml(UserMapper.java:87) at com.atlassian.crowd.migration.UserMapper.exportXml(UserMapper.java:71)

Cause

There are one or more users without any passwords in your Crowd internal directory.

Resolution

Follow the SQL below to check for user without password;

1 2 3 4 select * from cwd_user where credential = null; // Or select * from cwd_user where credential = '';

Reset the user password via the Crowd Console.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.