Cannot Start Crowd due to 'Unable to delete file' Error

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Crowd does not start, the following error appears in the atlassian-crowd.log:

1 2 3 4 5 6 7 8 9 10 11 Caused by: java.io.IOException: Unable to delete file: /var/atlassian/application-data/crowd/caches/felix/felix-cache/bundle6/bundle.lastmodified at org.apache.commons.io.FileUtils.forceDelete(FileUtils.java:1919) at org.apache.commons.io.FileUtils.cleanDirectory(FileUtils.java:1399) at org.apache.commons.io.FileUtils.deleteDirectory(FileUtils.java:1331) at org.apache.commons.io.FileUtils.forceDelete(FileUtils.java:1910) at org.apache.commons.io.FileUtils.cleanDirectory(FileUtils.java:1399) at org.apache.commons.io.FileUtils.deleteDirectory(FileUtils.java:1331) at org.apache.commons.io.FileUtils.forceDelete(FileUtils.java:1910) at org.apache.commons.io.FileUtils.cleanDirectory(FileUtils.java:1399) at com.atlassian.plugin.osgi.container.impl.DefaultOsgiPersistentCache.validate(DefaultOsgiPersistentCache.java:87) ... 115 more

Cause

Tomcat cannot make the necessary changes to Crowd Home folder, most likely due to lack of permission to do so.

Resolution

Check the file permissions for the Crowd Home folder and ensure the user running Crowd has full read/write to the directory and all sub directories.

Updated on April 8, 2025

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