Cannot connect with Crowd after upgrade/restore/restart

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

After a system restore/restart/upgrade, users will be locked out of Crowd and will be unable to authenticate in JIRA.

The following appears in the atlassian-crowd.log:

1 2 2014-12-24 06:57:22,786 http-bio-8095-exec-3 ERROR [crowd.console.action.Login] Failed to connect to the authentication server, please check your crowd.properties org.springframework.security.authentication.AuthenticationServiceException: Could not invoke service.. Nested exception is org.codehaus.xfire.fault.XFireFault: Server returned error code = 404 for URI : http://your.url.com/crowd/services/SecurityServer. Check server logs for details

Cause

The Crowd Client can't resolve the Crowd Server's URL.

Resolution

Edit the crowd.properties file located in your Home-Directory folder (defined at <Crowd-Install>/crowd-webapp/WEB-INF/classes/crowd-init.properties) so that it can resolve the URL locally.

Replace:

1 crowd.server.url=http://your.url.com/crowd/services/SecurityServer

with

1 crowd.server.url=http\://localhost\:8095/crowd/services/

ℹ️ You can also use the ip address rather than localhost if you so wish. Ensure that the port number is correct.

You will need to restart crowd for the changes to take effect.

If this doesn't work for you, clear your browser cookies then try accessing the Crowd client once again. It caches the previous incorrect path, despite making the suggested change above

Updated on April 8, 2025

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